SSL Verification Errors on PyPI
Incident Report for Python Infrastructure
Resolved
Routing the traffic away from the London POP appears to have solved the issue.
Posted about 1 year ago. Jul 31, 2013 - 10:42AM UTC
Monitoring
A routing loop was detected in the London POP for the CDN. That POP is being drained and SSL Certificate Validation should either be working or begin working shortly.

Thanks to everyone who helped identify and debug this issue and thanks to Fastly for the quick turn around on resolving once identified.
Posted about 1 year ago. Jul 31, 2013 - 10:16AM UTC
Update
Issue has been raised with the upstream provider and they are looking into it. Will let you know when I have more information.
Posted about 1 year ago. Jul 31, 2013 - 10:09AM UTC
Identified
Cause appears to be one of the IP addresses returned in the Geo DNS for Europe returning a certificate for addvocate.com. It's not clear at this time *why* that IP address is returning a certificate for addvocate.com
Posted about 1 year ago. Jul 31, 2013 - 9:51AM UTC
Update
Reports of work arounds by changing DNS entries to 8.8.8.8, possibly something wrong with the DNS
Posted about 1 year ago. Jul 31, 2013 - 9:31AM UTC
Update
Some reports that the errors are intermittent and that attempting to run things again may work.
Posted about 1 year ago. Jul 31, 2013 - 9:20AM UTC
Investigating
There appears to be a problem affecting a number of users where SSL verification errors will be shown saying "pypi.python.org" does not match "addvocate.com".

As Best we can tell this appears to be related to the ISP. It seems to be affecting folks using O2 or O2 related companies. We've also reports of it affecting people using Free.

It is not affecting everyone but everyone affected seems to be in Europe.
Posted about 1 year ago. Jul 31, 2013 - 8:56AM UTC