Sporadic SSL Errors on PyPI

Incident Report for Python Infrastructure

Resolved

We've been unable to re-reproduce the SSL issue, it appears that there are no longer any issues connecting.
Posted 11 years ago. Mar 28, 2014 - 15:58 UTC

Monitoring

A node with an old SSL certificate was found in the CDN, that SSL certificate has been updated and everything should be working now.
Posted 11 years ago. Mar 28, 2014 - 15:29 UTC

Investigating

We've gotten reports of sporadic SSL errors claiming that the host name doesn't patch when attempting to connect to PyPI. We've escalated to our CDN provider and are awaiting word.
Posted 11 years ago. Mar 28, 2014 - 13:31 UTC