Some PyPI web requests failing.
Incident Report for Python Infrastructure
Resolved
This incident has been resolved.
Posted Aug 01, 2023 - 20:09 UTC
Monitoring
The revert has been deployed and we are monitoring the result.
Posted Aug 01, 2023 - 20:03 UTC
Update
We have initiated a rollback of the change that introduced this outage.
Posted Aug 01, 2023 - 19:56 UTC
Identified
An update to our database connection library has caused some web requests including uploads to fail. We have identified the issue and are working to resolve.
Posted Aug 01, 2023 - 19:42 UTC
This incident affected: PyPI (pypi.org - Backends).