Service Interruption due to database upgrades

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted 4 years ago. Dec 17, 2021 - 12:14 UTC

Monitoring

Database maintenance is now complete and services are back online. We are monitoring the stability of backend services.
Posted 4 years ago. Dec 16, 2021 - 23:23 UTC

Update

Upload functionality is now restored. We are monitoring our database load before bringing the UI back online.
Posted 4 years ago. Dec 16, 2021 - 23:17 UTC

Update

Database upgrade is completing and we are working to bring the backends back online soon.
Posted 4 years ago. Dec 16, 2021 - 22:59 UTC

Identified

PyPI is currently experiencing interruptions due to a major database upgrade that cannot be performed online. We did not recognize this would occur when initiating the upgrade. Service will be operational once the upgrade completes.
Posted 4 years ago. Dec 16, 2021 - 22:29 UTC
This incident affected: PyPI (pypi.org - Backends).