PyPI database issues
Incident Report for Python Infrastructure
Resolved
Some slow Postgres queries combined with newer queries using the SERIALIZABLE isolation level led to high lock contention until we ran out of database connections. The offending queries have been fixed and the system is recovering.
Posted Aug 23, 2015 - 06:56 UTC
Monitoring
The deadlocked queries have been zapped, PyPI should be coming back up shortly.
Posted Aug 23, 2015 - 06:30 UTC
Investigating
PyPI has been switched to the static site due to some database connection issues. Package installation is not affected, uploads will be unavailable for a short time.
Posted Aug 23, 2015 - 06:14 UTC