Slow updates to PyPI pages/API responses

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 16:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2025 - 15:50 UTC

Investigating

We are currently observing a slowdown in background requests processing for events on PyPI.org
This could lead to stale web pages and API responses as the events system is not able to purge the caches.
Our team is continuing to investigate.
Posted Nov 12, 2025 - 15:46 UTC
This incident affected: PyPI (pypi.org - General, pypi.org - CDN, pypi.org - Backends, pypi.org - Email).