Intermittent availability issues for PyPI

Incident Report for Python Infrastructure

Resolved

PyPI has stabilized. Postmortem forthcoming with action taken and plans for long term mitigation.
Posted 9 years ago. Jun 09, 2016 - 17:51 UTC

Monitoring

We have take action to block some abusive parties and are monitoring pypi's response times and error rate to verify.
Posted 9 years ago. Jun 09, 2016 - 16:25 UTC

Identified

We have identified two concurrent processes which are overloading PyPI's backends with expensive requests, and taking action to remediate their impact.
Posted 9 years ago. Jun 09, 2016 - 15:07 UTC

Investigating

We are investigating intermittent issues with our CDN for PyPI
Posted 9 years ago. Jun 09, 2016 - 15:01 UTC