Download file corruption

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted 19 days ago. Mar 11, 2025 - 13:39 UTC

Update

We are continuing to monitor for any further issues.
Posted 19 days ago. Mar 11, 2025 - 13:05 UTC

Monitoring

Our CDN provider has reported that the node in question has been removed from service. We are monitoring for continued reports.
Posted 19 days ago. Mar 11, 2025 - 12:50 UTC

Identified

This issue appears to be isolated to a single edge node in our CDN provider's network. They have validated the issue and are working to resolve.
Posted 19 days ago. Mar 11, 2025 - 12:47 UTC

Investigating

We are investigating issues with files from files.pythonhosted.org being served with corrupted data. A support ticket has been opened with our CDN provider and we are awaiting their response.
Posted 19 days ago. Mar 11, 2025 - 12:13 UTC
This incident affected: PyPI (files.pythonhosted.org - Files).