Certificate Expired on PyPI
Incident Report for Python Infrastructure
Resolved
This incident has been resolved.
Posted Dec 08, 2016 - 12:32 UTC
Monitoring
The upstream provider has identified the issue and appears to have resolved the issue, will monitor for awhile. Please report if you get any more SSL verification errors.
Posted Dec 08, 2016 - 03:56 UTC
Update
Here is the status page for our CDN provider's tracking of this issue: https://status.fastly.com/incidents/3nvqmv1xdrmx
Posted Dec 08, 2016 - 03:33 UTC
Update
It appears the expired/stale certificate issue is affecting python.org as well as PyPI. Likely will also affect docs.python.org.
Posted Dec 08, 2016 - 03:22 UTC
Investigating
It appears that some users are getting a verification error due to an expired certificate on PyPI. There *should* be a certificate that is valid until 2018, but it appears some users are being served an older, expired certificate.
Posted Dec 08, 2016 - 03:18 UTC
This incident affected: python.org (python.org - CDN) and docs.python.org (docs.python.org - Backends).