Denial Of Service
Incident Report for Python Infrastructure
Resolved
We're weathering the incoming floods much more gracefully now and a full mitigation will be in place as soon as DNS propagation completes. Resolving for now!
Posted Mar 28, 2018 - 15:53 UTC
Monitoring
We've tuned the backend that was bearing the brunt of the attack to attempt to mitigate the incoming floods of bogus traffic and are monitoring the efficacy of our measures.
Posted Mar 28, 2018 - 14:43 UTC
Identified
We've configured the redirect from python.org => www.python.org to take affect at the CDN edge rather than our backend servers. This should reduce the impact of trivial DoS floods, but will take up to 24 hours to propagate. We're monitoring and tuning our backends to try to reduce the impact in the interim.
Posted Mar 28, 2018 - 14:24 UTC
Investigating
We are working to mitigate a Denial of Service attack against our infrastructure, sites hosted on the target are currently experiencing intermittent outages.
Posted Mar 28, 2018 - 14:02 UTC
This incident affected: python.org (python.org - CDN), docs.python.org (docs.python.org - Backends), and us.pycon.org.