CDN Anycast issues
Incident Report for Python Infrastructure
Resolved
The initial reports have been resolved. We're tracking a few other issues that are not likely related directly.
Posted 3 months ago. May 04, 2018 - 12:18 UTC
Monitoring
We have not heard any new reports of access issues and are continuing to monitor. If you do experience access issues to files.pythonhosted.org, please follow the instructions found here: https://github.com/pypa/warehouse/issues/3885#issuecomment-386438449
Posted 3 months ago. May 03, 2018 - 22:22 UTC
Update
We've been notified by our provider that they have deployed changes that may improve the situation and have requested updates from users who reported ongoing issues.
Posted 3 months ago. May 03, 2018 - 21:44 UTC
Identified
We're still receiving reports of Anycast IP access issues for files.pythonhosted.org.
Posted 3 months ago. May 03, 2018 - 20:59 UTC
Monitoring
We are monitoring for CDN issues, but our reproducible case has stopped failing.
Posted 3 months ago. May 03, 2018 - 19:35 UTC
Investigating
We are investigating reports of issues accessing services hosted by our CDN when accessing via Anycast IPs.

Anycast is used for apex domains of python.org, pythonhosted.org, and pypi.org. Additionally users who query DNS from Google DNS and OpenDNS receive Anycast IPs in response for other services which are hosted by our CDN, as the provider cannot localize the result.

We are working with the CDN provider to determine what is causing this, and the scope of the impact is unclear.
Posted 3 months ago. May 03, 2018 - 15:43 UTC
This incident affected: PyPI (pypi.org, files.pythonhosted.org - Files, files.pythonhosted.org - Redirects) and python.org, docs.python.org, bugs.python.org, us.pycon.org.