Notice: PyPI Mass CDN Purge
Incident Report for Python Infrastructure
Resolved
Our CDN hit rate and latencies have recovered, this event is now resolved.
Posted Jul 29, 2022 - 19:01 UTC
Update
Error rates have returned to baseline, and latencies continue to return to normal across our services. We will continue to monitor as the database upgrades complete and caches re-fill.
Posted Jul 29, 2022 - 16:30 UTC
Update
Our backends have begun to stabilize as the caches are refilled. During the peak of the backend traffic from our CDN we recognized a few bottlenecks in our database layer and have provisioned additional storage IOPs in order to reduce impact of surges in the future.
Posted Jul 29, 2022 - 16:03 UTC
Update
Purge All has been issued and we are monitoring as the backends attempt to meet the request volume. We anticipate that the service will continue to stabilize and reach steady state over the next 30-90 minutes.
Posted Jul 29, 2022 - 15:30 UTC
Monitoring
In order to resolve an issue in our CDN cache caused by a misconfiguration of Surrogate-Keys, PyPI will need to issue a "Purge All" of our CDN to clear out lingering cached objects that are not accessible to purge individually.

This purge is very likely to impact performance when accessing PyPI for some time.

In order to avoid purges like this in the future, our backends have been configured with Surrogate-Keys that will at least allow us to purge specific endpoint types rather than the entire service.
Posted Jul 29, 2022 - 15:19 UTC
This incident affected: PyPI (pypi.org - CDN, pypi.org - Backends).