PyPI Outage
Incident Report for Python Infrastructure
Resolved
PyPI's systems are back in a stable state and we've issued a purge to clear the caches of any stale content that was caused by the outage.
Posted 26 days ago. Oct 18, 2018 - 13:07 UTC
Monitoring
PyPI's backend systems are back online and we are monitoring to ensure stability.
Posted 26 days ago. Oct 18, 2018 - 12:52 UTC
Identified
A core component of the platform entered a crash loop due to memory consumption which cascaded into a broader failure as other services were unable to obtain and renew security tokens and tls certificates. We are in the process of bringing things back into a good state.
Posted 26 days ago. Oct 18, 2018 - 12:40 UTC
Investigating
We are investigating an outage of PyPI that is rooted in our internal hosting platform.
Posted 26 days ago. Oct 18, 2018 - 12:21 UTC
This incident affected: PyPI (pypi.org).