mail.python.org smtp down
Incident Report for Python Infrastructure
Resolved
Things appear to be going smoothly. We'll be reviewing over the coming days and will update as necessary.
Posted 7 months ago. Feb 21, 2019 - 22:31 UTC
Update
We're continuing to keep an eye on things, but it appears all services on mail.python.org are restored.
Posted 7 months ago. Feb 21, 2019 - 17:25 UTC
Monitoring
Mail handling services are back online and we are monitoring to ensure things are working properly.
Posted 7 months ago. Feb 21, 2019 - 17:01 UTC
Identified
A misconfiguration in our configuration management system caused mail and smtp settings on mail.python.org to be reverted to defaults, which are not appropriate for it's role.

We are working to restore service.
Posted 7 months ago. Feb 21, 2019 - 16:48 UTC
Investigating
mail.python.org's mail transfer services are currently experiencing an outage.
Posted 7 months ago. Feb 21, 2019 - 16:27 UTC
This incident affected: mail.python.org (Message Handling Services).