Deprecation of support for non-SNI clients.
Incident Report for Python Infrastructure
Resolved
This incident has been resolved.
Posted May 11, 2021 - 09:40 UTC
Update
In order to provide visibility for this deprecation and give people a chance to test their fixes we will be implementing rolling brownouts of non-SNI support beginning today. The mechanism will follow similar pattern to our TLS1.0/1.1 deprecation.

See https://github.com/pypa/pypi-support/issues/978 for details on the schedules for these brownouts.
Posted Mar 31, 2021 - 18:05 UTC
Update
We now have a new date for rollout of deprecation for non-SNI compatible clients.

**Between May 3rd and May 6th 2021**, a more precise date will be available as the window nears.

At some point during that week, non-SNI clients will stop being able to access pypi.org, files.pythonhosted.org, as well as other properties served by our CDN.

After the initial rollout began, a number of users reached out to Fastly directly, which led to them temporarily rolling back the change. During the rollback a certificate issue was encountered that required re-verifying our domain. This lead to a number of similar but only *slightly* related issues, as well as quite a bit of confusion for everyone involved.
Posted Mar 26, 2021 - 19:18 UTC
Monitoring
Clients that do not support SNI (Server Name Indication) will begin to experience disruptions accessing services that are served via our CDN.

Primarily impacted are Python 2.6 and older. See more information at https://github.com/pypa/pypi-support/issues/978
Posted Mar 24, 2021 - 14:25 UTC
This incident affected: python.org (python.org - CDN), PyPI (pypi.org - CDN, files.pythonhosted.org - Files, files.pythonhosted.org - Redirects), docs.python.org (docs.python.org - CDN), and us.pycon.org.