PyPI File Hosting Latencies and Timeouts

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted 2 years ago. Jan 10, 2023 - 17:43 UTC

Monitoring

We're seeing improvements after reports from our backend providers that their incident is resolved.
Posted 2 years ago. Jan 10, 2023 - 17:37 UTC

Update

We're continuing to investigate with our CDN, but found a potentially related outage published by our backend that we are now tracking as well.
Posted 2 years ago. Jan 10, 2023 - 16:26 UTC

Update

We are working with our CDN provider to determine what is contributing to these latencies.
Posted 2 years ago. Jan 10, 2023 - 14:15 UTC

Investigating

We are investigating issues with files.pythonhosted.org causing larger files to experience large latencies and timeouts.
Posted 2 years ago. Jan 10, 2023 - 13:59 UTC
This incident affected: PyPI (files.pythonhosted.org - Files).