PyPI Database Upgrades
Incident Report for Python Infrastructure
Resolved
All maintenance is complete and telemetry around database and application performance have stabilized. This incident is complete.
Posted Jun 08, 2024 - 14:52 UTC
Update
All upgrade steps are complete and performance is stabilizing. A final maintenance task is taking place in the background which will minimally impact performance until it is complete.
Posted Jun 08, 2024 - 14:42 UTC
Update
We are in the final steps of the upgrade and should see performance and availability stabilize in the next 30 minutes.
Posted Jun 08, 2024 - 14:26 UTC
Monitoring
Underlying upgrades are complete, we are running database statistics updates to optimize performance.
Posted Jun 08, 2024 - 13:58 UTC
Identified
We will be performing database maintenance including version upgrades and storage re-configuration. This will result in several brief outages for the service.
Posted Jun 08, 2024 - 13:43 UTC
This incident affected: PyPI (pypi.org - General, pypi.org - CDN, pypi.org - Backends).