PyPI Maintenance
Incident Report for Python Infrastructure
Resolved
Maintenance is complete! We generally try to avoid maintenance like this but required this update to continue progress on the rollout of the next-gen PyPI, https://github.com/pypa/warehouse
Posted 9 months ago. Mar 10, 2018 - 14:25 UTC
Update
We've completed the first of two migrations. The second should complete in the next 5 minutes and we'll be back online if all goes well.
Posted 9 months ago. Mar 10, 2018 - 14:21 UTC
Monitoring
PyPI requires a database migration that necessitates an exclusive lock on a busy table.

In order to perform this we're going to temporarily place PyPI into maintenance mode.
Posted 9 months ago. Mar 10, 2018 - 14:06 UTC