Database Storage Latencies

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted 1 year ago. Oct 17, 2023 - 22:44 UTC

Identified

A burst balance for our cloud storage disks that host our databases was exhausted. We are going to migrate to storage that will allow us to respond by adding more IOPS.
Posted 1 year ago. Oct 17, 2023 - 19:44 UTC

Investigating

We are investigating and responding to widespread issues with databases in our infrastructure showing poor performance due to cloud block storage.
Posted 1 year ago. Oct 17, 2023 - 19:32 UTC
This incident affected: python.org (python.org - Backends) and PyPI (pypi.org - Backends).