PyPI Elevated Error Rates

Incident Report for Python Infrastructure

Resolved

This incident is resolved. We're going to do some further investigation to understand what led to the lock contention.
Posted 3 months ago. Apr 24, 2025 - 12:18 UTC

Monitoring

The locking process has been terminated and we're monitoring as things recover.
Posted 3 months ago. Apr 24, 2025 - 12:09 UTC

Identified

We've identified an issue with database contention arising from locking.
Posted 3 months ago. Apr 24, 2025 - 12:09 UTC

Investigating

We're investigating elevated error rates for pypi.org
Posted 3 months ago. Apr 24, 2025 - 12:02 UTC
This incident affected: PyPI (pypi.org - Backends).