Issues with search, logins and logged-in pages

Incident Report for Python Infrastructure

Resolved

A fix has been implemented and the incident is closed.
Posted Sep 23, 2026 - 17:05 UTC

Monitoring

The traffic has subsided and the cluster is stable. A performance fix has been drafted.
Posted Sep 23, 2026 - 14:06 UTC

Investigating

We are currently investigating this issue.
Posted Sep 23, 2026 - 11:02 UTC
This incident affected: PyPI (pypi.org - General, pypi.org - Backends).