Outage

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted 3 years ago. Dec 29, 2021 - 20:00 UTC

Monitoring

We identified and resolved an issue in our database causing the CPUs to be exhausted. An index which should have been utilized for a common query was being bypassed by the planner. After forcing a statistics run of the table in question the query performance returned to expected performance. We are monitoring the status of the database now and are researching methods of avoiding this in the future.
Posted 3 years ago. Dec 29, 2021 - 19:39 UTC

Investigating

PyPI is currently experiencing an outage, and we are investigating.
Posted 3 years ago. Dec 29, 2021 - 18:31 UTC
This incident affected: PyPI (pypi.org - CDN, pypi.org - Backends).