PyPI has switched to the Static Mirror

Incident Report for Python Infrastructure

Resolved

PyPI load has stabilized.
Posted 10 years ago. Aug 06, 2015 - 18:23 UTC

Monitoring

We've had a load spike that seems to have subsided for now, will monitor the situation.
Posted 10 years ago. Aug 06, 2015 - 18:01 UTC

Investigating

We are currently investigating this issue.
Posted 10 years ago. Aug 06, 2015 - 17:54 UTC