PyPI Uploads failing

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 23:00 UTC

Monitoring

We identified a database lock causing contention and stopped all upload backends to release all locks and are monitoring for recovery.
Posted Jan 07, 2026 - 22:59 UTC

Investigating

We are investigating why PyPI uploads are failing.
Posted Jan 07, 2026 - 22:42 UTC
This incident affected: PyPI (pypi.org - Backends).