Inbound emails delayed for @python.org
Incident Report for Python Infrastructure
Resolved
This incident has been resolved.
Posted 10 months ago. Jul 25, 2018 - 23:48 UTC
Monitoring
Mail delivery has been restored. We are monitoring the backlog of emails as the server catches up on it's queue of emails to handle.
Posted 10 months ago. Jul 25, 2018 - 21:28 UTC
Identified
The issue has been identified and a fix is being deployed.
Posted 10 months ago. Jul 25, 2018 - 21:08 UTC
Investigating
We are investigating emails sent to @python.org addresses including mailing lists being delayed.
Posted 10 months ago. Jul 25, 2018 - 20:42 UTC
This incident affected: mail.python.org (Message Handling Services).