PyPI Simple and JSON API Outage

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted 12 days ago. Apr 08, 2025 - 11:00 UTC

Update

Errors have subsided, and we are monitoring as things continue to recover.
Posted 12 days ago. Apr 08, 2025 - 10:31 UTC

Monitoring

We've increased capacity in the worker pools that service /simple and /json and are monitoring as things recover.
Posted 12 days ago. Apr 08, 2025 - 10:26 UTC

Identified

We are working to resolve an outage impacting our /simple and /json apis.
Posted 12 days ago. Apr 08, 2025 - 10:23 UTC
This incident affected: PyPI (pypi.org - CDN, pypi.org - Backends).