python.org outage
Incident Report for Python Infrastructure
Resolved
We're solid for now!
Posted about 1 year ago. Apr 30, 2018 - 19:24 UTC
Monitoring
We've determined that the code used to display recent blog posts on the python.org homepage was attempting to call out to resolve `legacy.pypi.org`, which was included in a recent blog.python.org post... however that service was shutdown this morning.

The blog post has been pulled to keep it from being rendered and we're working to determine what codepath was causing the timeouts.
Posted about 1 year ago. Apr 30, 2018 - 18:36 UTC
Update
We are working on determining the issue more closely. A networked resource loaded on the homepage is causing timeouts.
Posted about 1 year ago. Apr 30, 2018 - 17:55 UTC
Identified
The internal network that connects our load balancers to the servers running python.org's code is experiencing an outage. We are working to resolve the issue.
Posted about 1 year ago. Apr 30, 2018 - 16:56 UTC
Investigating
Python.org is erroring for all users, we are investigating.
Posted about 1 year ago. Apr 30, 2018 - 16:41 UTC
This incident affected: python.org.