pypi.org and upload.pypi.org down

Incident Report for Python Infrastructure

Resolved

pypi.org and upload.pypi.org backends are stable, we're continuing to monitor and will address and tune as necessary.
Posted 7 years ago. Feb 21, 2018 - 20:16 UTC

Monitoring

We've deployed our solution to and are monitoring the results!
Posted 7 years ago. Feb 21, 2018 - 19:08 UTC

Update

We have a fix going out that will stop our backends from running out of memory! This should lead to a much more stable pypi.org and upload.pypi.org endpoints!
Posted 7 years ago. Feb 21, 2018 - 18:57 UTC

Identified

we are experiencing issues with pypi.org and the upload.pypi.org endpoint. we're actively working to resolve the issue and will update here as we're able.
Posted 7 years ago. Feb 21, 2018 - 16:33 UTC