PyPI Search Index Degraded

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 19:58 UTC

Monitoring

The PyPI search index has degraded and is not returning results.
A reindexing job has begun, and results will be available once it completes.
Posted Jul 29, 2025 - 14:41 UTC
This incident affected: PyPI (pypi.org - Backends).