Intermittent 503 errors on PyPI

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted 10 years ago. May 15, 2015 - 06:26 UTC

Monitoring

We've resolved the bulk of the issues with the migration to S3 and PyPI should be back to it's regular speed again. We'll be monitoring to make sure that there are no more problems.
Posted 10 years ago. May 15, 2015 - 04:16 UTC

Update

We've mitigated part of the problem and problematic requests should be responding quicker now, there is still however more issues which are currently being remedied.
Posted 10 years ago. May 15, 2015 - 03:06 UTC

Identified

You may see intermittent 503 errors on PyPI due to a move to storing data files on S3 exposing very inefficient code which can sometimes take longer than the maximum request time to complete. We are working on fixing this and will hopefully have it done shortly.
Posted 10 years ago. May 14, 2015 - 23:49 UTC