Uploads are failing intermittently
Incident Report for Python Infrastructure
Resolved
We have seen errors subside over the last 16 hours, and uploads are succeeding as usual.
Posted 2 years ago. Mar 28, 2023 - 13:59 UTC
Update
We are continuing to monitor for any further issues.
Posted 2 years ago. Mar 27, 2023 - 20:35 UTC
Monitoring
The upstream provider has identified the issue as being resolved and we have seen failures subside over the last hour. We are continuing to monitor for regressions.
Posted 2 years ago. Mar 27, 2023 - 20:34 UTC
Update
We are still observing intermittent upload failures and have contacted our upstream provider for support.
Posted 2 years ago. Mar 27, 2023 - 17:29 UTC
Investigating
We are currently investigating an intermittent outage with our upstream object storage provider, causing uploads for new releases to fail intermittently with a "503: Service Unavailable".
Posted 2 years ago. Mar 27, 2023 - 14:34 UTC
This incident affected: PyPI (pypi.org - General).