PyPI Backends Unavailable
Incident Report for Python Infrastructure
Resolved
This incident has been resolved.
Posted Dec 14, 2019 - 19:21 UTC
Identified
A set of TLS certificates in our provisioning and management system expired leading to a cascading failure of internal tools that rely on it. These certificates have been renewed and we are working to roll them out across the tools. Services are coming back online.
Posted Dec 14, 2019 - 17:46 UTC
Investigating
We are currently investigating this issue.
Posted Dec 14, 2019 - 17:10 UTC
This incident affected: PyPI (pypi.org - CDN).