PyPI: Backends down
Incident Report for Python Infrastructure
Resolved
Our search cluster provider has confirmed their fix and are verifying. We'll be resolving ours and will open a new incident if further disruptions occur.
Posted 6 months ago. May 04, 2018 - 02:16 UTC
Update
Our search cluster has recovered. We have completed work to finalize safeguards against this kind of outage in the future as well.

We'll continue to monitor for a period before resolving this incident.
Posted 6 months ago. May 04, 2018 - 01:57 UTC
Monitoring
Interim fix is deployed. Search queries in the UI and XMLRPC API are not operational.
Posted 6 months ago. May 04, 2018 - 01:35 UTC
Update
We're preparing a short term workaround while our search provider recovers.
Posted 6 months ago. May 04, 2018 - 01:25 UTC
Update
We've confirmed that uploads, simple index, JSON API, and file downloads are not affected.
Posted 6 months ago. May 04, 2018 - 01:17 UTC
Update
We've confirmed the issue with our hosted search provider and are working to resolve.
Posted 6 months ago. May 04, 2018 - 01:14 UTC
Identified
Our search cluster is currently down. Due to timeouts being set too high in our client libraries, the frequency of search requests is tying up all of our backend resources leading to health check timeouts.
Posted 6 months ago. May 04, 2018 - 01:11 UTC
Investigating
We are investigating a down situation for the PyPI backends. Web UI, Uploads, and API access may be impacted.
Posted 6 months ago. May 04, 2018 - 01:08 UTC
This incident affected: PyPI (pypi.org).