PyPI Degraded Service
Incident Report for Python Infrastructure
Resolved
This incident has been resolved.
Posted Nov 25, 2020 - 22:17 UTC
Monitoring
Service has been restored with the upstream provider, and we are monitoring for regressions.
Posted Nov 25, 2020 - 17:59 UTC
Investigating
An upstream hosting provider is experiencing increased API errors.
Posted Nov 25, 2020 - 16:47 UTC
This incident affected: PyPI (pypi.org - CDN, pypi.org - Backends).