Intermittent outages in PyPI backends.

Incident Report for Python Infrastructure

Resolved

This incident has been resolved.
Posted 2 years ago. Aug 17, 2023 - 15:08 UTC

Monitoring

The migration has been completed and we are monitoring to ensure stability.
Posted 2 years ago. Aug 17, 2023 - 15:05 UTC

Identified

A slow migration PyPI admins are attempting to apply is causing database contention leading to intermittent outages in the PyPI backends. We are working on mitigating the impact to end users.
Posted 2 years ago. Aug 17, 2023 - 15:00 UTC
This incident affected: PyPI (pypi.org - Backends).